코드이그나이터 기반 PHP 오픈소스 게시판 : 씨아이보드

씨아이보드 최소 설치 버전 변경

안녕하세요 씨아이보드 관리자입니다.

 

씨아이보드 설치 가능한 php 최소 버전이 5.2.4 에서 5.3.0 으로 변경되어서 알립니다.

 

그 동안에는 PHP 5.2.4 이상에서 설치가 가능하였었습니다. 그러나 PHP의 버전이 이제 7.0.x 까지 나온 상황에서 5.2.x 의 버전을 더 이상 지원이 어렵게 되어, 설치 가능 버전을 5.3.0 으로 변경합니다.

 

주된 이유는 namespace 의 활용입니다. github 에 올라온 여러가지 공개소스도 namespace 를 많이 활용하였고, 씨아이보드도 기회가 되면 이를 활용해보려 합니다.

 

기존에 5.2.x 버전을 사용하고 계셨던 회원님들께서는, Browscap 기능만 사용하지 않으신다면 계속하여 5.2.x 버전에서 씨아이보드 사용이 가능합니다.

 

참고로, 코드이그나이터 자체적으로 권장하는 php 버전은 5.4.0 이상입니다. 

(참조 : https://www.codeigniter.com/user_guide/general/requirements.html )

 

따라서 가능하시다면 최소 5.4.0 이상을 사용하시길 권장합니다.

 

감사합니다.

 

공지사항

번호 제목 글쓴이 날짜 조회수
공지 프리미엄 버전의 판매는 중단 되었습니다. +16 icon 관리자 08-09 8,935
공지 휴대폰본인인증, 아이핀본인인증 기능 런칭 icon 관리자 04-08 9,762
공지 씨아이보드 테이블구조 icon 관리자 03-22 10,747
공지 PHP 7 지원 +3 icon 관리자 02-01 8,162
공지 씨아이보드 매뉴얼 +4 icon 어드민 08-31 9,658
공지 CI 3.0 한글 매뉴얼 +3 icon 어드민 08-24 8,616
8 코드이그나이터 3.0.5 적용 +1 icon 관리자 03-14 3,987
7 매뉴얼 업데이트 +1 icon 관리자 02-11 4,224
6 씨아이보드 최소 설치 버전 변경 icon 관리자 02-01 3,784
5 배포버전 1.3.8 재배포 안내 icon 관리자 01-10 3,437
4 프리미엄 다운로드 이용권 가격 정책 변동 +2 icon 관리자 12-01 4,025
3 소셜로그인 기능 런칭 +2 icon 관리자 09-15 3,833
2 카드결제 가능 icon 어드민 08-12 4,030
1 사이트 오픈 안내 icon 어드민 07-30 3,186