코드이그나이터 기반 PHP 오픈소스 게시판 : 씨아이보드

배너관련 문의드립니다~

좋은 빌더 공개해 주셔서 감사합니다^^


1b6e45e41221415fafe5989b66da71a2.png 


위 사진과 같이 배너를 등록했구요~

FTP에 확인해 보니 /uploads/banner/2017/11 밑으로 3개의 png 파일이 잘 올라가 있습니다.


문제는 메인페이지에 배너가 보이질 않는데요.



/views/_layout/bootstrap/layout.php에서...


<!--bxslider script-->
<script type="text/javascript" src="<?php echo base_url('assets/js/bxslider/jquery.bxslider.js'); ?>"></script>
<link href="<?php echo base_url('assets/js/bxslider/jquery.bxslider.css'); ?>" rel="stylesheet" />


  <!-- main slider start -->
  <div class="main_slide_wrapper clearfix">
    <div class="main_bxslider">

    <?php
     foreach($view['banner_list']['banner_main'] as $i => $row){
 ?>
      <div class="main_slide slide<?=$i?>" style="background: url('<?= $base_URL ."/uploads/banner/". $row['ban_image']?>'); background-size: cover; background-size:center center;">
        <div>
          <span class="before"></span>
        </div>
      </div>
    <?php } ?>

    </div>

    <div class="main_btn_controls container" style="display:none;">
      <a href="" class="main_slide_btn prev_btn"></a>
      <a href="" class="main_slide_btn next_btn"></a>
    </div>
  </div>
  <!-- main slider end --> 


<script>
  // 메인 슬라이드
  // main 화면 일 경우 :: .main_bxslider
  if (location.pathname == "/"){
    var is_mobile = '<?=$this->cbconfig->get_device_view_type() === 'mobile'?>';
   var mainSlider = $(".main_bxslider").bxSlider({
    pager: false,
      controls: false,
      auto: true,
      speed: 800,
      pause: 4000,
      easing: 'ease-in-out',
      autoHover: true,
      onSliderLoad: function(){

        var h = $('.main_slide_wrapper .bx-viewport').height();
        $('.main_slide_wrapper .main_btn_controls').height(h).css({"margin-top":-h});
        if(!is_mobile){
          $('.main_btn_controls').show();
        }
      }
   });

    $('.main_slide_wrapper .next_btn').click(function(){
      mainSlider.goToNextSlide();
      return false;
    });
    $('.main_slide_wrapper .prev_btn').click(function(){
      mainSlider.goToPrevSlide();
      return false;
    });

  }
</script>


이렇게 관련 라이브러리 넣고 배너를 삽입했는데...

배너이미지가 보이질 않습니다. ㅜㅜ


도움 부탁드립니다.






0
0
이 글을 페이스북으로 퍼가기 이 글을 트위터로 퍼가기 이 글을 카카오톡으로 퍼가기 이 글을 카카오스토리로 퍼가기 이 글을 밴드로 퍼가기

질문/답변

번호 제목 글쓴이 날짜 조회수
공지 Github 운영을 시작합니다 +12 icon 관리자 11-19 15,875
공지 씨아이보드 3 배포 안내 +20 icon 관리자 11-09 17,732
421 자동로그인 질문입니다. +2 perfume 01-09 1,976
420 smtp 설정(확인 완료) +1 링닝 01-09 2,122
419 소스가 이상하게 되어있어요 뗘기 01-09 1,962
418 에디터에서 이미지 등록시 lightbox 사용문의 +2 perfume 01-08 2,209
417 CIBoard 설치 시 스타일 문제? 경로문제? +1 좋아서죽음 01-05 2,119
416 로그인 부분 질문입니다.. +1 아기새 12-26 3,001
415 parent::__construct(); +1 아기새 12-26 2,334
414 cb_board 테이블의 +2 김영준 12-24 2,046
413 액티브 레코드 질문있어요 곰은곰곰 12-22 1,732
412 설치시 Internal Server Error납니다~ +2 이근원 12-19 5,387
411 홈페이지 접속시 바로 로그인 화면으로 가는 방법있나요? +2 특곰 12-13 2,372
410 회원가입 커스터마이징 질문입니다. perfume 12-09 1,682
409 관리자메뉴에서 어드민으로 회원추가할 때 이상한게 생겼어요 +2 곰은곰곰 12-08 2,160
408 captcha 문의 합니다. +1 하경이아빠 12-08 1,999
407 메인화면 +1 드봉 12-07 2,013
406 파일 업로드 관련 질문이 있습니다 쥐엘와이씨 12-06 2,400
405 CI보드 최저 사양이 어떻게되나요? +1 LovelyCaT 11-29 2,484
404 ci보드로 사이트 만들고 있는데.. 최은귀 11-17 2,044
403 콘텐츠몰에서 분류별로 메뉴를 구성하여 아이템을 표시하는 방법 문의 드립니… +2 컴삿갓 11-16 1,964
402 배너관련 문의드립니다~ 와이즈시스템즈 11-15 2,177