코드이그나이터 기반 PHP 오픈소스 게시판 : 씨아이보드

씨아이보드 베이직 1.3.5

  • 관리자
  • 3
  • 3,837
  • 글주소
  • 11-25

이전 버전에서 browscap 플러그인을 추가하는 과정 가운데에, namespace 를 사용하게 되어서, namespace 를 지원하지 않는 php 하위 버전에서 오류가 있었습니다. 이에 namespace 부분을 제거하고 순수 class 로 변경하여 다시 배포합니다.

 

수정 내역​

browscap 클래스 수정

관리자페이지에서 browscap 캐시 업데이트시 이벤트 추가

 

수정된 파일

application/config/cb_version.php

application/controllers/admin/config/Browscapupdate.php

application/helpers/basic_helper.php

plugin/browscap/Browscap.php